Back to overview
Downtime
Power Outage
Feb 11 at 05:22am HST
Affected services
Website
Better Teknikk V3 Cloud
Product Hub API
Resolved
Feb 11 at 11:50pm HST
We found the issue and everything is back up
Affected services
Created
Feb 11 at 05:22am HST
We got a Power Outage at home, means all JET Services won't be available for now
Affected services